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PAM GUI/Client hanging after logging in

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Article ID: 227721

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

PAM GUI/Client hanging after logging in.  We recently upgraded our UAT environment to 3.4.5.  Everything was fine for several weeks.   However, for the past 3 days, shortly after logging in, the GUI seems to hang/freeze.  I can no longer click on any menu dropdowns, etc. 

Only option is to open another session and log in again which usually works. (not always).

Cause

Only one environment was updated to 3.4.5. Another environment was at a lower release still, but the same client was used to connect to it. When a PAM client instance is connected to a PAM server at one release, and the same client installation is used to connect to a PAM server at a different release, the updater fails because it cannot update the updater jar file in the PAM client installation folder.

Environment

Release : 3.4.x, 4.0.x, 4.1.0

Component : PRIVILEGED ACCESS MANAGEMENT

Resolution

For a given PAM client installation, all previously started instances have to be closed before connection to a PAM server running a different release.

We recommend to install a second PAM client into a different folder, if you have need to connect to PAM servers at two different releases. In general use a dedicated PAM client installation for each PAM server version you may want to connect to from your desktop client. Running multiple instances of the same PAM client to connect to different PAM servers at the same release is ok.