Slowness modifying filters by non-Symantec Administrators role Users
search cancel

Slowness modifying filters by non-Symantec Administrators role Users

book

Article ID: 227644

calendar_today

Updated On:

Products

IT Management Suite Client Management Suite

Issue/Introduction

You have been receiving complaints from other ITMS users in your organization that are not in the Symantec Administrator role of slowness when modifying filters. This is not when modifying filters under Activity Center (Enhanced Views) (Manage>Computers),

but when modifying filters the older way, from Manage > Filters. 

You tested with other built-in roles and experienced the same issue, like Level 2 Workers or Symantec Supervisors.
If you add your test account to Symantec Administrators, it works quickly. To see if it was a permissions issue, you cloned the Symantec Administrators role and added your test account to that, also removing it from the original Symantec Administrators. Surprisingly, it was back to loading slowing again.
By slow, we mean that it takes over 30 seconds just to load the page for some commonly used filters, and then about another 30 seconds for the page to change after hitting the Edit button.

These are filters with explicit inclusions, and nothing else. You are considering that it may have something to do with the number of resources included in the target. The complaints come in regarding the time it takes to load and edit filters that have over 5000 computers included. For example, with your test account, you are toggling between one target with 160 computers, which comes up quickly, and with 5693 computers, which is taking some time.

Environment

ITMS 8.5 RU4, 8.6, 8.6 RU1

Cause

Known issue. Dev detected the need to refactor our code and optimize both SQL and C# parts as much as possible around this portion of the SMP Console. "spGetSecurityGuidsForItemGuids" stored procedure needed some optimization as part of what needed some changes.

Resolution

A fix is currently planned for our ITMS 8.6 RU2 release.

No current workarounds besides loading the filters under Manage>Computers>Filters blade or adding these users to the Symantec Administrators role.