Spectrum / VNA integration stuck in "Waiting for VNA response"
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Spectrum / VNA integration stuck in "Waiting for VNA response"

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Article ID: 227594

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Updated On:

Products

CA Spectrum

Issue/Introduction

After upgrading Spectrum and VNA to version 21.2.2, the status for all domains on the OneClick integrated with VNA is  "Waiting for VNA response".

I already fixed the missing username / passwords on the VNA side and all collectors show as "connected" on the VNA aggregator as described here:

After upgrade to VNA 21.2, the Spectrum integration breaks with domain unavailable

However, the status is unchanged for five hours now.  It seems like the issue described in

Unable to receive alarms in Spectrum from any VNA site after a network restart, but this is supposed to be fixed since NetOps 20.2.

The mysql output from the VNA Aggregator "mysql> show full processlist;" shows all VNA aggregator Daemons with a Sleep State.

 

 

Environment

Release : 21.2

Component : Spectrum Integrations

Cause


Trouble shooting done:

- Verified the Aggregator to VNA collectors communication and do not see any issue
- After a manual on-demand sync from Spectrum no request was received to Aggregator and all domains are shown waiting for sync to complete.
- Restarted the OneClick server but the aggregator still has received no request.  
- Enabled runtime debug on the OC web server  “VNA Integration Information” 

After analyzing the spectrum OC tomcat logs, we identified the hostname is changed from FQDN to a short name.  The checkForActiveServer is false - the host name  does not match.
from tomcat log.
Oct 28, 2021 07:26:25.173 (https-jsse-nio-8443-exec-7) (SDNIntegrationServlet) - Checking if this is the active server
Oct 28, 2021 07:26:25.173 (https-jsse-nio-8443-exec-7) (SDNIntegrationServlet) - Stored Hostname: <FQDN>
Oct 28, 2021 07:26:25.173 (https-jsse-nio-8443-exec-7) (SDNIntegrationServlet) - Local Hostname: <short hostname>

Resolution

Updating the SDN_Enabled_OC_Server with FQDN the issue is resolved.  SDN_Enabled_OC_Server (0x6730005) is on SDN Manager model.

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/spectrum/21-2/integrating/ca-spectrum-and-ca-virtual-network-assurance-ca-vna/integrating-ca-spectrum-with-ca-virtual-network-assurance/ca-vna-standalone-and-aggregator-integration.html#concept.dita_7f5549282e78b9b08141bcf98f9169dd3ed638c9_HandlingSpectrumVNASync