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Unexpected WSS Agent behaviour when logged user name contains non-ascii characters

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Article ID: 227582

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Updated On:

Products

Web Security Service - WSS

Issue/Introduction

Windows users running WSS Agents to access internet via WSS

Functionality working well for most users

Users with accented characters in the username e.g. NoëlC do not show up in the WSS Portal agent access menu ("Disable" option does not even show when allowed)

WSS reports showing user name as computer name without user name (for example, "WIN10\" instead expected "WIN10\саша").

Nonetheless, WSS agent successfully connects to WSS, when logged user name contains non-ascii characters.

Cause

Bug with WSS agent forwarding user information when it includes certain extended characters

Resolution

Apply WSS agent 7.4.2 or greater.

Attachments