Symantec Management Agent service failed to start
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Symantec Management Agent service failed to start

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Article ID: 227532

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Updated On:

Products

IT Management Suite

Issue/Introduction

Symantec Management Agent failed to start:

Error in the Windows event logs:

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID

{06FA962D-B817-4349-8219-93F97AB359D0}

 and APPID

{5E038245-CF81-44BE-8018-9A2981B9DC9B}

 to the user NT AUTHORITY\IUSR SID (S-1-5-17) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

Environment

ITMS 8.x

Cause

SYSTEM account does not have the 'set local launch' and 'local activation' permissions.

Resolution

  • Click Start -> Run -> Type -> dcomcnfg, expand Component Services -> Computers -> My Computer -> DCOM Config.
  • Click View -> Detail -> Now you will get the Application Name and Application ID on the right side.
  • Scroll down and find the application ID {5E038245-CF81-44BE-8018-9A2981B9DC9B}. It might be for the 'Altiris Agent'.
  • Right Click -> Properties and select the Security tab.
  • Click Customize under "Launch & Activation Permission" -> click Edit -> Add in the account SYSTEM and set local launch and local activation.
  • Restart the application Service linked to this Application ID (Symantec Management Agent), or restart the server and monitor