R12.3 Desktop Client cannot connect to DE (ESP dSeries) 12.2
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R12.3 Desktop Client cannot connect to DE (ESP dSeries) 12.2

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Article ID: 227302

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Updated On:

Products

CA Workload Automation DE CA Workload Automation DE - Scheduler (dSeries) CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

Users with R12.3 desktop client is build 3623 are unable to connect to DE (dSeries) R12.2 build 2394.

Environment

Release : 12.3

Component : Workload Automation ESP dSeries 

Cause

If an older DE version (e.g 12.2 to 12.3)  was upgraded and then restored back then the DB may still have new version property data.  The tracelog will show entires like these:

deserver.exampl.com:7500)] [receive] - CTOKEN(80000000) VERSION RESPONSE BUILD_VERSION(R12.1) VERSION_FROM_DB(12.3.00.00) BUILD_ID(2394) BUILD_DATE(202005041800)

......

2021-10-13 10:25:47,165 trace [CA_NONPROD (deserver.exampl.com:7500)] [receive] - CTOKEN(A0000000) 03 000000 ESPWSS0000E Cannot create command CLIENTVERSION 12.3.
2021-10-13 10:25:47,176 trace The command channel [deserver.exampl.com:7500] has been closed.

 

 

Resolution

When an older version is upgrade and reverted back the DB may still have information about new release.  This can result in Desktop Client version not being properly recognized and will result in disconnect.  Use the older version of Desktop Client to connect to to DE server.  When backing out of an upgrade, always take back up of database and restore to pre-upgrade state.