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Sybase authentication fails after account update

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Article ID: 227087

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

Sybase target accounts can be updated successfully, but when we try to use the new password to log on, we get an authentication error. It looks like this is observed when the new password contains special characters.

Cause

A recent vulnerability fix inadvertently escaped special characters in passwords in a way that made the escape characters part of the password when it was sent by PAM for authentication.

Environment

Release : 3.4.0-3.4.5 and 4.0.0

Component : PRIVILEGED ACCESS MANAGEMENT

Resolution

As of October 2021 the problem is fixed in 4.0.1, see the following item on page Resolved Issues in 4.0.1:

32780662, 32840634
DE512345, DE514051
Authentication issue on account (CA PAM)

The problem will be fixed in the upcoming 3.4.6 release as well. If you are at a lower release and cannot upgrade to 4.0.1 at this time (or 3.4.6 once available), please open a case with PAM Support.