Sybase authentication fails after account update
search cancel

Sybase authentication fails after account update

book

Article ID: 227087

calendar_today

Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

Sybase target accounts can be updated successfully, but when we try to use the new password to log on, we get an authentication error. It looks like this is observed when the new password contains special characters.

Environment

Release : 3.4.0-3.4.5 and 4.0.0

Component : PRIVILEGED ACCESS MANAGEMENT

Cause

A recent vulnerability fix inadvertently escaped special characters in passwords in a way that made the escape characters part of the password when it was sent by PAM for authentication.

Resolution

As of October 2021 the problem is fixed in 4.0.1, see the following item on page Resolved Issues in 4.0.1:

32780662, 32840634
DE512345, DE514051
Authentication issue on account (CA PAM)

This issue is fixed in 3.4.6 and 4.0.1.  Please note the issue occurs in 3.4.0-3.4.5 and 4.0.0.