OAuth2 Configuration Fails
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OAuth2 Configuration Fails

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Article ID: 227081

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

Trying to configure OAuth2 for email..

Following the KB article:

Oauth Setup for Maileater
https://knowledge.broadcom.com/external/article?articleId=216187

I'm able to get all the way to the Generate Token button as the last step and when the form does a new pop up to https://SDM-SERVER:8443/CAisd/OAuthProcessor?authorize=1 it fails and give me the following error below (404 error). 

I tried to log into Office 365 on the same browser thinking it might jump to that, but it did not.

How do I get around this error in our newly upgraded development 17.3 RU9 application?

 

HTTP Status 404 – Not Found


Type Status Report

Message /CAisd/OAuthProcessor

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.


Apache Tomcat/8.5.53

Environment

Release : 17.3

Component : Svc Desk Email

Cause

During the RU9 application, the pdm_configure ran and overwrote the web.xml.  So the servlet and servlet-mapping were missing.

Resolution

Please review the post install steps for entry "OAuth 2.0 (Maileater/Mailer) Mandatory Post-Installation Tasks" described below:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/ca-service-management/17-3/installing/Installing-CA-Service-Management-17-3-0-9/Post-Installation-Tasks-for-CA-Service-Management-17-3-0-9.html