One or more cloud detectors went into a Disconnected state.
search cancel

One or more cloud detectors went into a Disconnected state.

book

Article ID: 227005

calendar_today

Updated On:

Products

Data Loss Prevention Discover Suite

Issue/Introduction

On the Enforce console, you have noticed that one or more cloud detectors are showing a "disconnected" state. 

Environment

Release : 15.8

Component : Cloud Detector

Cause

The most common reasons for the disconnect error is caused by timeout, or failed connection to the database. It may take multiple connection failures to cause this state, but is easily recoverable.  Another less common reason would be java heap sizes for the monitor controller wrapper.

For the first reason, here is an example of an error for database timeouts. If these are present, then this indicates the Enforce server is having trouble reaching the database, most likely network related.

Caused by: java.sql.SQLRecoverableException: IO Error: Socket read timed out
INFO   | jvm 1    | 2021/10/08 21:19:19 |  at oracle.jdbc.driver.T4CPreparedStatement.executeForDescribe(T4CPreparedStatement.java:790)
INFO   | jvm 1    | 2021/10/08 21:19:19 |  at oracle.jdbc.driver.OracleStatement.executeMaybeDescribe(OracleStatement.java:925)
INFO   | jvm 1    | 2021/10/08 21:19:19 |  at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1111)
INFO   | jvm 1    | 2021/10/08 21:19:19 |  at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:4798)
INFO   | jvm 1    | 2021/10/08 21:19:19 |  at oracle.jdbc.driver.OraclePreparedStatement.executeQuery(OraclePreparedStatement.java:4845)
INFO   | jvm 1    | 2021/10/08 21:19:19 |  at oracle.jdbc.driver.OraclePreparedStatementWrapper.executeQuery(OraclePreparedStatementWrapper.java:1501)
INFO   | jvm 1    | 2021/10/08 21:19:19 |  at com.vontu.util.jdbc.LoggingPreparedStatement.executeQuery(LoggingPreparedStatement.java:131)
INFO   | jvm 1    | 2021/10/08 21:19:19 |  at org.hibernate.engine.jdbc.internal.ResultSetReturnImpl.extract(ResultSetReturnImpl.java:60)

 

If these errors are not present in the logs, you can search the term "Java Heap" in the monitor controller logs. If there is a java heap error, you will need to increase the java heap sizes. 

Resolution

If caused by Java heaps for Monitor Controller (found in logs), increase Java heap sizes. Start with doubling the Max  java heap size, recycle the Enforce service and monitor.  

Instructions: https://knowledge.broadcom.com/external/article/160263/monitor-controller-performance-issues-af.html

 

If caused by Database, you will need to launch an investigation with the database team to see why timeouts are happening.