Java Version match on Master and agent
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Java Version match on Master and agent

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Article ID: 226940

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

Do we need to use matching java versions on master and remote agent?

Our master is currently using openjdk version "11.0.10" 2021-01-19 LTS
OpenJDK Runtime Environment 18.9 (build 11.0.10+9-LTS)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.10+9-LTS, mixed mode, sharing)

However, the remote agent is running the following:

java -version
openjdk version "1.8.0_282"
OpenJDK Runtime Environment (build 1.8.0_282-b08)
OpenJDK 64-Bit Server VM (build 25.282-b08, mixed mode)

Environment

CA Automic Applications Manager 9.3x

Cause

Mismatch of java version on agent and master.

Resolution

There is no requirement for matching version of type and java on the master / remote agent and you should be able to use any compatible version of java per our compatibility matrix found here:

https://docs.automic.com/jart/prj3/dlc/main.jart?rel=en&reserve-mode=active&content-id=1458225673388&compatibility-mode=component&component_id=1409731987518&lifecycle_entity_id=1409731986339

However, it is highly recommended to use the same version and type of java on master/agent because Java can easily make a change in the newer java version which breaks the AM connection if the master is using the new version and the agent is not.

Additional Information

A good example scenario would be the one described in the KB below:

https://knowledge.broadcom.com/external/article?articleId=190850

The KE talks about how Java 8 update 201 changes can break the connection if one component if running equal or greater than 201 and the other is running less then 201.