Unable to load licenses from NS server. The request failed with the error message: -- <head><title>Document Moved</title></head>
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Unable to load licenses from NS server. The request failed with the error message: -- <head><title>Document Moved</title></head>

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Article ID: 226938

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Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

Symantec Installation Manager (SIM) returns the following error as seen in the Log Viewer when trying to make a change to the SQL server configuration:

Unable to load licenses from NS server.
The request failed with the error message:
--
<head><title>Document Moved</title></head>
<body><h1>Object Moved</h1>This document may be found <a HREF="https://<NS Server>/Altiris/NS/Services/LicensingWebService.asmx">here</a></body>
--.
   [System.Net.WebException @ System.Web.Services]
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Altiris.NS.Licensing.LicensingWebServiceProxy.GetLicenseStatus()
   at Symantec.Installation.Model.LicenseManager.<LoadLicensesFromServer>d__33.MoveNext()
   at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
   at Symantec.Installation.Model.LicenseManager.LoadFromServer(Func`1 getLicXml)
   at Symantec.Installation.Model.LicenseManager.LoadLicenses()

Exception logged from: 
   at Symantec.Installation.Logging.LogActivity.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)
   at Symantec.Installation.Logging.LogActivity.ReportException(String strMessage, String category, Exception exception)
   at Symantec.Installation.Model.LicenseManager.LoadLicenses()
   at Symantec.Installation.Model.LicenseManager.RefreshLicenses(Boolean force)
   at Symantec.Installation.Model.LicenseManager.<RefreshLicensesTask>b__44_0()
   at System.Threading.Tasks.Task.Execute()
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.Tasks.Task.ExecuteWithThreadLocal(Task& currentTaskSlot)
   at System.Threading.Tasks.Task.ExecuteEntry(Boolean bPreventDoubleExecution)
   at System.Threading.ThreadPoolWorkQueue.Dispatch()


-----------------------------------------------------------------------------------------------------
Date: 10/22/2021 11:34:05 AM, Tick Count: 296431359 (3.10:20:31.3590000), Host Name: <NS Server>, Size: 2.41 KB
Process: SymantecInstallationManager (1472), Thread ID: 13, Module: SymantecInstallationManager.exe
Priority: 1, Source: Symantec.Installation.Model.LicenseManager.LoadLicenses

Environment

Release: ITMS 8.5 RU4

 

Cause

The Notification Server didn't have access to www.solutionsam.com. Also, was an HTTP to HTTPS redirect using URL Rewrite. 

Resolution

Fixed by enabling internet access to www.solutionsam.com and disabling the IIS HTTP to HTTPS redirect using URL Rewrite.