CCS How to Troubleshoot Query is hanging
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CCS How to Troubleshoot Query is hanging

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Article ID: 226915

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Updated On:

Products

Control Compliance Suite Standards Server

Issue/Introduction

Control Compliance Suite, running a query job and it is hanging

Environment

Release : 12.5.2

Component :

Cause

Could be the scope of the job, just a lot of data that is being collected making it appear that the job is hung.

Or could be a sick CCS Manager

Resolution

Enable Job Traceability to help identify the CCS Manager(s) doing the collection.  Can get details if the threads for the Manager are obsolete or not.

Job traceability

Dumping a job trace

Option is available in CCS console’s jobs view to dump trace for an executing job. However, the option is not enabled by default. Following steps needs to be done to enable the option:

  • In the CCS console folder take a back up of this file, then open Applications\jobs\ jobs.monitor.application.xml
    • On W2K8+ open Task Manager à go to SymConsole.exe process à select ‘Open File Location’
  • Search for keyword ‘Traceability:’ and uncommented the specified XML tags (There are two tags to be uncommented)
  • Tags are <!-- and -->. Just move the --> tag up to the end of the line with <!--
  • Launch the console
  • The traceability option is available under ‘Job run tasks’ in jobs view

The job trace is dumped as an HTML/XML. The required data is present in hierarchical way i.e. job can be traced from APS to DPS to WorkerProcess or parent job to child job. Traceability to agent is not covered.

The trace is available only for running jobs\sub-jobs and not for completed jobs\sub-jobs.

Once the option is enabled in console then trace can be dumped for selected job or all running jobs. From the Jobs workspace use the 3 dots dropdown menu to access the "Trace running jobs" option.
If the job is not showing up just select the option to dump all jobs.