HTTP Timeouts when opening policies - Server Error in 'Altiris/SoftwareManagemenetSolution' Application
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HTTP Timeouts when opening policies - Server Error in 'Altiris/SoftwareManagemenetSolution' Application

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Article ID: 226901

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Updated On:

Products

Client Management Suite

Issue/Introduction

When opening a policy, it fails to load with the following error:

The Notification Server logs include the following:

HTTP Request failed:

/Altiris/SoftwareManagementSolution/ManagedDelivery/TaskDetails.aspx?ItemGuid=885ac997-b517-4936-8cb0-2a60aab09540

Request timed out.

Environment

ITMS 8.x

Cause

IIS execution time out while loading the page.

 

Resolution

Increasing the ExecutionTimeout in the website which is shown in the error could resolves this issue:

  • Open IIS manager to edit the executionTimeout setting (found under /Altiris/SoftwareManagementSolution/ManagedDelivery Click on "Configuration Editor"):
    • IIS> NS> Sites> Default Website> Altiris> SoftwareManagementSolution > Managed Delivery

   

  • Under the Configuration Editor, make sure you have selected "System.web/httpRuntime" under the Section dropdown
  • Change the "ExecutionTimeout" value from "00:01:50" to "00:10:00" minutes and click Apply.