ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Zowe DB2 plugin: how to configure Zowe to call DB2 11.1

book

Article ID: 226895

calendar_today

Updated On:

Products

Brightside

Issue/Introduction

Installed site license for DB2 version 11.1,  then followed ZOWE IBM DB2 plugin  document link to install DB2 plugin. 

Zowe DB2 CLI command shows DB2 server connection failure due to licensing problem. DB2 server is calling for license version 11.5, how to configure Zowe to call DB2 license 11.1 ? 

Environment

Release : 3.0

Component : BRIGHTSIDE ZOWE CLI

Zowe IBM DB2 plugin

Resolution

Uninstall Zowe DB2 plugin (`zowe plugins uninstall @zowe/db2-for-zowe-cli`), then follow the instruction below:

      • Select the newest version that is compatible with DB2 11.1 (currently Mod 4 Fix Pack 6)
      • Select the ODBC CLI driver for your system, likely the 2nd-to-last download "IBM Data Server Driver for ODBC and CLI (64-bit)"
      • Download the ZIP file and proceed with steps from Zowe docs to place it in "odbc_cli" folder

Attachments