Messaging Gateway maillog contains ipfreq_cleanup error messages
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Messaging Gateway maillog contains ipfreq_cleanup error messages

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Article ID: 226787

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Updated On:

Products

Messaging Gateway

Issue/Introduction

MTA logs show the following error

(err) ipfreq_cleanup: [-] [Brightmail] (ERROR:29482.2926384960): [10058] Error getting file status /data/scanner/rules/ipfreq.db.

Cause

The SMG Scanner is attempting to perform regular maintentance on the database which manages local IP connection reputation for the Connection Classification and is unable to lock the IP reputation database.

Resolution

This error does not affect message scanner or delivery and only indicates a temporary condition when performing regular maintenance.

If you are concerned by the error or it occures frequently, the local IP reputation database can be manually reset using the following procedure. This will, however, erase all local IP reputation history and SMG will begin building IP reputation from an empty database.

  1. Log into the SMG scanner command line interface (CLI) as admin
  2. Run delete ipfreqrules

This will need to be performed on all SMG scanners which are generating the error.