ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

ASM - Puppet 3 is required for the OPMS installation, version '' found.

book

Article ID: 226686

calendar_today

Updated On:

Products

CA App Synthetic Monitor

Issue/Introduction

We are failing to install OPMS 10.7.0.1 and the install log doesn't show any errors:

Summary
-------
Installation: Successful.

2447 Successes
0 Warnings
0 NonFatalErrors
0 FatalErrors

Action Notes:
None

 

but yum logs reports:  "Puppet 3 is required for the OPMS installation, version '' found.

Environment

OPMS 10.7.0.1

Resolution

In order to address this problem check the following points:

- Make sue EPEL repository is accessible in the OS 
- Check for any existing puppet package and remove any puppet version other than 3.8.7:
yum list installed | grep puppet

Also run these commands:
which puppet
puppet --version 2

These commands are used to check if puppet is there and what the version is.

- Install manually (yum localinstall) puppet 3.8.7 version
- Launch the OPMS installer

If the problem persists, please contact Broadcom Support.