Migrate PC Portal to server with new install owner and install home
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Migrate PC Portal to server with new install owner and install home

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Article ID: 226634

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Following the documented migration process for Performance Center moving the Portal from old to new hardware.

After following the documented steps the services are failing to start and we see references to the old server install home path.

Environment

All supported DX NetOps Performance Management releases

Cause

Documentation assumes new destination host uses same install owner and same install home path.

Resolution

The following solution options are listed with the best/easiest recommended options listed first.

  1. Use the same user name and install home on both source and destination systems. Follow existing Migrate NetOps Portal documentation.
  2. Use the following Disaster Recovery steps specific to the Portal.
    1. Install NetOps Portal on the new destination system
    2. Back up the source system using the Back Up NetOps Portal documentation
    3. Move the backed up source system files to the new destination system. Restore the files/data using the Restore NetOps Portal documentation.
    4. Run the NetOps Portal disaster recovery script.
      1. It is the (default path) /opt/CA/PerformanceCenter/Tools/bin/update_pc_da_database_references.sh script.
      2. Update the first two sections with the new values for:
        • PC IP
        • PC Hostname
        • PC Event Producer Port and Protocol
        • DA IP
        • DA Hostname
        • DA Port
        • MySql User and Password
      3. Save the changes and run the script.
  3. If neither is possible post migration the following changes will be required. NOTE: All paths referenced are the default install home path.
    1. Ensure the /etc/systemd/system/caperfcenter_*.service files have the correct install home path and user name set.
    2. Ensure the RUN_AS_USER value in the /opt/CA/PerformanceCenter/<service>/bin/caperfcenter_<service> is set to the correct install owner user name.
    3. Ensure all files under /opt/CA are owned by the correct new user.
    4. Ensure all files under /opt/CA/MySql/data and /opt/CA/MySql/tmp are owned by the correct mysql user.
    5. Ensure all paths in the /etc/my.cnf file are set to the correct new install home path.
    6. Ensure all paths in the /opt/CA/PerformanceCenter/<service>/conf/wrapper.conf files are set to the correct new install home path.
    7. Ensure all paths in the /opt/CA/PerformanceCenter/Tools/bin/SslConfig.lax file are set to the correct new install home path.
    8. Ensure all paths in the /opt/CA/PerforanceCenter/sso/bin/SsoConfig.lax file are set to the correct new install home path.
    9. Correct any symbolic paths using the wrong home install path from the /opt/CA/PerformanceCenter directory
      • Can use the "unlink <fileName>" command to break an existing link.
      • Can use the command "ln -s /<NewPath>/FileName <fileName>" to set the new path. For example to set a new link for the SsoConfig command to the default install home the command is:
        • ln -s /opt/CA/PerformanceCenter/sso/bin/SsoConfig SsoConfig"

The services should now start and run properly.