Error connecting to DSM Server, SME_SEC_NEED_CREDS, INF010
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Error connecting to DSM Server, SME_SEC_NEED_CREDS, INF010

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Article ID: 226612

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Updated On:

Products

CA Client Automation CA Client Automation - IT Client Manager CA Client Automation - Patch Manager

Issue/Introduction

User can log into the Web Console and accept a patch. It fails to register the patch in the DSM.

The PMEngine.log shows the errors:

...
2021-10-19 11:08:24,705 [DownloadedPatchTask] ERROR [com.ca.pmengine.infrastructure] - connect(): failed
2021-10-19 11:08:24,721 [DownloadedPatchTask] FATAL [com.ca.pmengine.eventmanager] - Error connecting to DSM Server. Reason: SME_SEC_NEED_CREDS The client must provide explicit credentials to complete authentication as unified logon is not available.
2021-10-19 11:08:24,721 [DownloadedPatchTask] FATAL [com.ca.pmengine.eventmanager] - Missing Resource ID:INF010
2021-10-19 11:08:24,721 [DownloadedPatchTask] FATAL [com.ca.pmengine.eventmanager] - java.util.NoSuchElementException: Could not create a validated object
...
2021-10-19 11:08:24,721 [DownloadedPatchTask] ERROR [com.ca.pmengine.decision] - Patch 2018-04 Security Only Update - windows8-rt-kb4093122-x64 {ac2c7eb5-cac2-405c-a050-b683ef35764a} package registration failed
2021-10-19 11:08:24,721 [DownloadedPatchTask] ERROR [com.ca.pmengine.decision] - Patch 2018-04 Security Only Update - windows8-rt-kb4093122-x64 {ac2c7eb5-cac2-405c-a050-b683ef35764a} status changed from STATUS_PACKAGING to STATUS_DOWNLOAD_FAILED
...

After verified the credentials the problem persisted.

Environment

Client Automation - All versions

Cause

The IPV6 was disabled on the network interface .

After that, ping to server name used an IPV6 address of [::1, which is loopback].

Resolution

Enable the IPV6 and set to prefer using IPV4 over IPV6.:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters]
"DisabledComponents"=dword:00000020

See ref. link:

Guidance for configuring IPv6 in Windows for advanced users

Additional Information

Regarding return codes SME_SEC_NEED_CREDS and INF010, see also:

 

Client Automation - Packaging Failed and INF010 in PMEngine log Article ID: 100043

The "DSM Service" status in UPM Dashboard appears in "failed" state Article ID: 48889

 

Also verify if the account exists in DSM - Security - security profiles

as an administrative account with full control.

And, make sure the service account being used for authentication is enabled.