NS connection to SQL server failed. Symantec_CMDB (In Recovery)
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NS connection to SQL server failed. Symantec_CMDB (In Recovery)

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Article ID: 226593

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Updated On:

Products

Client Management Suite

Issue/Introduction

Notification Server is not responsive and the SMP Console not loading after rebooting the SQL Server.  

Notification Server logs shows the following:

[5/5] SQL connection failed, current user='SERVICE ACCOUNT', total time=00:02:29.9670338

Connection Timeout Expired.  The timeout period elapsed during the post-login phase.  The connection could have timed out while waiting for server to complete the login process and respond; Or it could have timed out while attempting to create multiple active connections.  The duration spent while attempting to connect to this server was - [Pre-Login] initialization=9; handshake=14; [Login] initialization=0; authentication=0; [Post-Login] complete=29722;

Environment

ITMS 8.x

Cause

Checked the CMDB and found the Symantec_CMDB is written 'In Recovery'. Database had gone to recovery mode because of the reboot and apparently some corruption before that.
 

Resolution

Check the SQL Server logs to know the phase of the recovery. It will also show the estimated time needed for the recovery to complete.

If ithe recovery will take longer than usual to complete, this usually means that the database may have issues that were not able to be resolved. You may be better to restore the database to a safe backup.

NOTE: Check both the SQL server logs and the Altiris logs to know the reason of the crash.