Parent NS Not Replicating Jobs down to Child. The current user 'Service Account' does not have required permission 'read' to load item: GUID
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Parent NS Not Replicating Jobs down to Child. The current user 'Service Account' does not have required permission 'read' to load item: GUID

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Article ID: 226591

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Updated On: 05-06-2025

Products

Client Management Suite IT Management Suite

Issue/Introduction

Replication jobs are not replicating from the Parent to Child and there are many errors showing the App ID (Service Account) doesn't have access to different Directory connectors as seen here:

  • Unable to merge the specified duplicate resources:
    resource(to): 'ServerName' (1f430b8a-d366-4371-874d-64aaef8dbe38), duplicate(from): d31143c8-4a75-442b-88cf-2778e6d3a4bb, type: 2c3cb3bb-fee9-48df-804f-90856198b600

The current user 'Service account' does not have required permission 'read' to load item: d31143c8-4a75-442b-88cf-2778e6d3a4bb

  • Failed to load replication data class. [The current user 'Service account' does not have required permission 'read' to load item: 2280041b-5438-4965-9d0d-606f558b97e8]

Environment

ITMS 8.x

 

Cause

Service Account doesn't have enough permissions to the SQL server.

Resolution

This issue was resolved by adding the Service Account to the SQL server's administrators. (In Windows Server User Accounts).

 

 

Additional Information

For other SQL rights that are needed for the Application Identity service account (or SQL account), refer to the following article:

"What SQL rights are needed for the Application Identity service account (or SQL account)?"