Parent NS Not Replicating Jobs down to Child. The current user 'Service Account' does not have required permission 'read' to load item: GUID
search cancel

Parent NS Not Replicating Jobs down to Child. The current user 'Service Account' does not have required permission 'read' to load item: GUID

book

Article ID: 226591

calendar_today

Updated On:

Products

Client Management Suite

Issue/Introduction

Replication jobs are not working and there are many errors showing the App ID (Service Account) doesn't have access to different Directory connectors!

Errors:

  • Unable to merge the specified duplicate resources:
    resource(to): 'ServerName' (1f430b8a-d366-4371-874d-64aaef8dbe38), duplicate(from): d31143c8-4a75-442b-88cf-2778e6d3a4bb, type: 2c3cb3bb-fee9-48df-804f-90856198b600

The current user 'Service account' does not have required permission 'read' to load item: d31143c8-4a75-442b-88cf-2778e6d3a4bb

 

  • Failed to load replication data class. [The current user 'Service account' does not have required permission 'read' to load item: 2280041b-5438-4965-9d0d-606f558b97e8]

Environment

Release : 8.x

 

Cause

Service account doesn't have enough permissions to the SQL server.

Resolution

The issue got resolved after adding the service account to the SQL servers administrators. (In Windows Server User Accounts).

 

 

Additional Information

For other SQL rights which are needed for the Application Identity service account (or SQL account), you can check the following article:

KB 181352 "What SQL rights are needed for the Application Identity service account (or SQL account)?"