ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Error When trying to Integrate CABI jasperReports Server with CA Service Management

book

Article ID: 226590

calendar_today

Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

When trying to integrate CABI JasperReports Server with Service Management, the following error appears in the logs:

ERROR [DeployThread: Configuring CABI JasperReports Server ] [JasperServerConfigTask] CABI JasperReports Server configuration Task failed for : [] with error : 
java.lang.Exception: Unable to update data source for Transactional Reports  sdm_ds, refer logs for more details.
 at com.ca.smsi.installcore.util.JasperServerHelper.updateDataSourceforTransReports(JasperServerHelper.java:496)
 at com.ca.smsi.installcore.util.JasperServerHelper.configureCABI(JasperServerHelper.java:368)
 at com.ca.smsi.installui.tasks.JasperServerConfigTask.configureCABI(JasperServerConfigTask.java:148)
 at com.ca.smsi.installui.tasks.JasperServerConfigTask.run(JasperServerConfigTask.java:66)
 at com.ca.smsi.wizard.task.Task.start(Task.java:239)
 at com.ca.smsi.installcore.DeployThread.run(DeployThread.java:1309)

Cause

Pre-requisites to increase the length of the field which stores the password of sdm_ds 

Environment

Release : 17.3

 

Resolution

Solution

Implement the steps noted under Integration with JasperReports 7.2 – Changes in JasperReports Database

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/ca-service-management/17-3/installing/Installing-CA-Service-Management-17-3-0-9/Install-Prerequisites-for-CA-Service-Management-17-3-0-9.html#concept.dita_77db958a-791c-4808-a1e4-9c0ed323ebc9_MicrosoftSQL