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Unable to autoping new agent

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Article ID: 226588

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Updated On:

Products

CA Workload Automation AE

Issue/Introduction

Unable to autoping a new agent. The autoping receives the following error...

CAUAJM_I_50023 AutoPinging Machine [agent_host]

CAUAJM_E_10229 Communication attempt with the CA WAAE Agent has failed! [agent_host:7520]

CAUAJM_E_50281 AutoPing from the Scheduler WAS NOT SUCCESSFUL.

 

CAUAJM_E_10229 Communication attempt with the CA WAAE Agent has failed! [agent_host:7520]

CAUAJM_E_50283 AutoPing from the Application Server WAS NOT SUCCESSFUL.

 

CAUAJM_E_50026 ERROR: AutoPing WAS NOT SUCCESSFUL.

 


In the transmitter.log on the agent machine, the following error is logged when the autoping is attempted...

10/19/2021 16:05:44.657 EDT-0400 5 TCP/IP Controller Plugin.Transmitter pool thread <Slow:1>.CybTargetHandlerChannelLogHelper.logConnectionAttempt[:75] - Attempting to open conversation to [email protected]_host:7507 using plain socket

10/19/2021 16:05:44.657 EDT-0400 5 TCP/IP Controller Plugin.Transmitter pool thread <Slow:1>.CybTargetHandlerChannelLogHelper.logConnectionInfo[:109] - Opened conversation to [email protected]_host:7507 with partner at ##.#.##.###:7507 with timeout of 10000 from ##.#.##.###:57075


10/19/2021 16:05:44.657 EDT-0400 1 TCP/IP Controller Plugin.Transmitter pool thread <Slow:1>.CybTargetHandlerChannel.sendMessage[:627] - Error sending message to CENTRAL_MANAGER:
                                                                                                                                         cybermation.library.communications.CybConversationConnectionResetException: Reset by peer

 

 

Cause

While there can be a wide variety of root causes for an autoping failure, the key error to the one we are focusing on with this document is in the transmitter.log. The agent is attempting to open a connection back to the Scheduler and using a manager id called "CENTRAL_MANAGER"...

10/19/2021 16:05:44.657 EDT-0400 5 TCP/IP Controller Plugin.Transmitter pool thread <Slow:1>.CybTargetHandlerChannelLogHelper.logConnectionAttempt[:75] - Attempting to open conversation to [email protected]_host:7507 using plain socket


During the agent installation, it asks whether you want to add a manager to the agent configuration. If you take the default, parameters get added to the agent configuration for a single manager and the manager id is set to CENTRAL_MANAGER. The parameters in the agentparm.txt file will look like this...

communication.managerid_1=CENTRAL_MANAGER
communication.manageraddress_1=scheduler_host
communication.managerport_1=7507
communication.monitorobject_1=AGENT/AGENTMON1.0/MAIN

This manager id setting is not compatible with AutoSys. For an AutoSys instance, the manager id must be <INS>_SCH, where <INS> is the three-character name of the AutoSys instance.

Environment

Release : 11.3/11.4/11.5/12.0

Component : CA Workload Automation System Agent

Resolution

To correct this problem, make the following modifications to the agentparm.txt file...

Remove the default communication parameters for CENTRAL_MANAGER from the agentparm.txt...

communication.managerid_1=CENTRAL_MANAGER
communication.manageraddress_1=scheduler_host
communication.managerport_1=7507
communication.monitorobject_1=AGENT/AGENTMON1.0/MAIN

Add this parameter anywhere in the file...

communication.nomanagers.abort.disable=true

After the changes are made, restart the agent and the autoping should be successful. The correct manager parameters for the AutoSys instance will get added to the agentparm.txt file once you retry the autoping.