How to validate CEM Gateway connection to the SMP
search cancel

How to validate CEM Gateway connection to the SMP

book

Article ID: 226398

calendar_today

Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

Trying to add a server to the CEM Gateway Manager, and getting the error: "Web Exception occurred during Server Certificate request - Unable to connect to the remote server."

Environment

8.x

Cause

Error: Web Exception occurred during Server Certificate request - Unable to connect to the remote server.

Resolution

Open up the Gateway Manager Logs (General Tab > Miscellaneous > Start Altiris Log Viewer). Find the message that contains GetServerCertificate.aspx  Something like this:

Trying to get Server certificate. Request:https://ServerName:Port/Altiris/NS/Agent/GetServerCertificate.aspx?CRL=False&Version=8.6.2184.0&Guid=2722c959-384b-403f-90d9-f93d3ff62b00

If you click on that URL, it should pull up the Certificate in a Web Browser. Something like this:

-----BEGIN CERTIFICATE----- XXXXXXXXAv+gAwIBAgIUHf49jUZcwq5KZVSTX4sDprE3EzswDQYJKoZIhvcXXXXXXXAwMTEvMC0G A1UEAxMmU01XXXXlbmJkbDAwMDE3MC0wNi5FUE0ubG9jYXXXQWdlbnQgQ0EwHhcNMjAwNTA4MDYw 

Try that URL from your desktop, does it work? If the URL is unsuccessful from the Gateway, we have a communication problem between the SMP and the Gateway. This could be a HOSTS file, DNS, or a Firewall issue that needs to be addressed by the Networking team.

Additional Information

NOTE: The GUID in the URL request is the GUID of the SMP Internet Gateway (select * from [Inv_AeX_AC_Roles] where role = 'SMP Internet Gateway').  This URL won't be successful anywhere else but from the Gateway.