FDM UI not accepting seed list table after establishing SQL seedlist connection
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FDM UI not accepting seed list table after establishing SQL seedlist connection

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Article ID: 226374

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Updated On: 03-31-2025

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

When attempting to load an existing masking CSV file, which uses a SQL Server seed list table, I'm not able to progress to run the masking job. I am able to select the connection file from the drop-down and select the seed-list once the connection is established, but there is no way to proceed from the Windows dialogue screen.  Seem there is no button to accept or 'OK' button (which is missing from the seed list connection pop-up).

Environment

FDM 4.9.x

Cause

The root cause is the Windows 10 display settings. Looking at the screenshot, it appears the Windows 10 display for your user is set to 150%. The original FDM was implemented long before Windows 10, so it doesn't support non-default scales very well.

Resolution

There are a couple of options to correct this.

  1. Try reducing the display to 100% and see if the buttons are visible.
  2. Engineering has provided a fix in FastDataMasker-4.9.211.0.

Note: This behavior is more related to the embedded JRE that now ships with the more recent FDM releases, than with FDM itself. After applying the FDM patch, you still need to configure Java's behavior for high DPI settings. These steps can be applied for all users that access FDM, if you wish. Technically, you can make this change without applying the new patch, since this is related to the behavior of Java. This will fix the dialog window so that the buttons are displayed. However, the rest of the UI won't scale as it did with older versions of FDM.

To configure Java:

  1. Open a Windows File Explorer
  2. Navigate to <FDM_INSTALL_DIR>\jre\bin directory. By default, this is C:\Program Files\jre\bin
  3. Right-click on javaw.exe, and in the menu select "Properties". The "javaw.exe Properties" dialogue window will open.
  4. Select the "Compatibility" tab
  5. In the "Setting" section, select the "Change high DPI settings" button
  6. At the bottom of the dialogue window, select the "Override high DPI scaling behavior" checkbox.
  7. In the drop-down, select either "System" or "System (Enhanced)"
  8. Click "OK" to apply the changes.