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Impact explorer not adding CIs for role

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Article ID: 226365

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

Impact explorer not adding CIs for role.  This can be done using the admin role, but fails on the normal analyst role. 

Steps to reproduce

- Login as a user with the "Level 1 Analyst" role

- Access a given CO that has a CI present and access the Configuration Management Tab, Configuration Items sub-tab.  Locate an existing test CI that is present in the CI tab which has a child CI defined.

- Click on Impact Explorer and drill down on the test CI to expose the child CI

- Right click on the child CI and choose "Add to Change Order"

Result:  The child CI entry is not added to the CO through Impact Explorer.

Cause

This is working as designed.

The affected users are accessing the CO's as part of the "Level 1 Analyst" Role, which does not have the Function Access for "ci" (Configuration Item) to be set to Modify.  OOB, the Function Access for "ci" (Configuration Item) is set to View.  

Environment

Release : 17.3

Component : CA CMDB

Resolution

The affected users can use the "Update CI's" function in the Change Order to add CI's.  Alternatively, the given user's role can be set to allow the Function Access for "ci" (Configuration Item) be set to Modify.