Query LDAP fails to find user in active directory, Tests succeeds, Search via Identity Provider succeeds.
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Query LDAP fails to find user in active directory, Tests succeeds, Search via Identity Provider succeeds.

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Article ID: 226281

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Updated On:

Products

CA API Gateway

Issue/Introduction

Simple policy that includes LDAP Query assertions returned no entries found

Auditing show (sAMAccountName=<username>)  did not return any ldap entry 

Gateway 10 CR 2

 

Environment

Release : 10.0

Component :

Cause

Issue is caused by exception thrown when traverse the query result, code is change so no exception is thrown

Resolution

Known issue 

DE487301 Corrected an issue that caused the Query LDAP assertion to return no results.

https://techdocs.broadcom.com/us/en/ca-enterprise-software/layer7-api-management/api-gateway/10-0/release-notes/resolved-issues.html

Code fix has been merged to develop and 10CR03

Recommends applying the latest CR 4