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SpectroSERVER asserting the "MANAGEMENT AGENT LOST" alarms at the same time on multiple models managed using SNMP v3

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Article ID: 226249

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

SpectroSERVER asserting the "MANAGEMENT AGENT LOST" alarms at the same time on multiple models managed using SNMP v3

Cause

Spectrum caches the SNMP v3 profile data used to manage devices with SNMP v3. 

Sometimes, this cached profile data gets out of synchronization with the actual device that Spectrum is polling. When this happens, it causes false "MANAGEMENT AGENT LOST" alarms in Spectrum, even though Spectrum is using the correct Authentication credentials.

Environment

Release : 10.4.x, 20.2.x and 21.2.x

Component : Spectrum Core / SpectroSERVER

Resolution

The solution is to flush the SNMP v3 cache by doing the following:

1. Log into the SpectroSERVER system as the user that owns the Spectrum installation

2. If on Windows, start a bash shell by running "bash -login"

3. cd to the $SPECROOT/vnmsh directory and enter the following command to start a CLI session:

./connect

4. Enter the following command where <MH> is the model handle of the VNM model for this landscape:

./update action=0x10333 mh=<MH>

The SNMP v3 cache will be flushed and rebuilt as Spectrum communicates with the devices being modeled using SNMP v3.