Users do not receive emails when prompted to reset their password.
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Users do not receive emails when prompted to reset their password.

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Article ID: 226030

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Updated On:

Products

CA API Developer Portal

Issue/Introduction

Users do not receive emails when prompted to reset their password.

The page confirms the submission, but the user does not receive anything.

Verified that the Portal does not send the SMTP to trigger the emails.

 

NOTE For new registrations, users receive the emails without any problems.

 

Environment

Release : 5.0.2

Component :

Cause

Two different flows use different templates  

New registrations 

Reset password

The reset password was customized to request email, however the template functioning still used username  

Resolution

The RESET customization page request email, the code for this page is username 

The user would not be found by eMail 

The tenant would be sending the email it should be logged in the data container 

# docker service logs  portal_portal-data &>  portal_portal-data.log

Example of a NOT found 

portal_portal-data.0.ykkh6k79pz06@<servername>    | [tenant502-portal.log] [2021-10-07 21:33:55,800] [ERROR] [c.l.p.s.o.InitPasswordResetFunction] [http-nio-8080-exec-5] [cba6a448d7563d72c9f375eaf9ad88d0|3363e3f1409b2665] [tenant502||Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0|d70fbade995b$6508] Could not initiate password reset for user SallySideways 

portal_portal-data.0.ykkh6k79pz06@<server>    | com.layer7.portal.common.error.ResourceNotFoundException: SallySideways not found

Change page to input to username