Internal error: Unable to find any processes.

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Article ID: 226022

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Updated On:

Products

DX Infrastructure Management CA Unified Infrastructure Management for z Systems CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) NIMSOFT PROBES

Issue/Introduction

We have a Solaris server with this alert "Internal error: Unable to find any processes." andthe customer has told us that is everything is ok with that server.

I read a solution in this link: https://knowledge.broadcom.com/external/article/34291/processes-probe-internal-error-unable-to.html, so I modified  "use_perf = no"  and "retry_discover_limit = 3"  in the raw configure as the article stated, but the alert still occurred. Can you give me another solution to this issue?

Cause

- processes configuration needed adjustment

Environment

Release : UIM 20.3

Component : UIM - PROCESSES

- processes 4.80

- OS: Solaris 11

Resolution

In the processes.cfg change the following settings to the values listed below:

<setup>
   loglevel = 5
   logfile = processes.log
   interval = 180
   samples = 2
   sample_all = 1
   retry_discover_limit = 2
   username_length_unix = 8
   virtual_memory = 1
   real_memory = 0
   use_perf = no
   logsize = 100000
   auto_clear_restart_alarm = true
   get_full_command_line = no
   get_all_running_processes_info = no
   clear_all_alarms_on_restart = no
   process_memory = PageFile
   groups_enabled = no
   user_type = 0
   exclude = Idle
   is_upgrade = 0
</setup>
 
Then Deactivate the processes probe, wait for the port and PID to disappear.

Then Activate and test again.

In this case/scenario, no further "Internal error: Unable to find any processes." alarms/alerts were generated.