ConcurrentModificationException ERROR from Odata request
search cancel

ConcurrentModificationException ERROR from Odata request

book

Article ID: 225957

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Data Aggregator Odata queries are failing.

What is the solution for these ERROR messages seen in the odata-services.impl.log file? The log file is found in (default path) /opt/IMDataAggregator/apache-karaf-<version>/data/log.

ERROR | 092710283-887988 | <DATE> <TIME> | ODataRequestProcessor | odata.impl.ODataRequestProcessor 1161 |       | Failed to complete request (Thread id 887988): host: '1.1.1.1' tenant: 'Default Tenant' user: 'admin' url: 'http://<DAHostName>:8581/odata/api/jittermfs?$format=json&&resolution=RATE&starttime=1632284399&endtime=1632284699&timeout=90&$top=60000&$skip=0&$expand=device,component&$select=ID,Timestamp,im_PathAvailability,im_PctSuccessfulAttempts,im_Attempts,im_SuccessfulAttempts,im_PacketsLossDestSrc,im_PacketsLossSrcDest,im_PacketsLost,im_AvgResponseTime,im_AvgOneWayDelaySrcDest,im_AvgOneWayDelayDestSrc,im_JitterIn,im_JitterOut,im_MaximumNegativeJitterIn,im_MaximumPositiveJitterIn,im_MaximumNegativeJitterOut,im_MaximumPositiveJitterOut,device/Name,device/IPDomainID,component/Service_Type,component/Name,component/Description&$filter=((groups/GroupPathLocation  eq '<GroupNamePath>'))' - Execution time 4970 ms. Error: java.util.ConcurrentModificationException

Environment

All DX NetOps Performance Management releases r21.2.1 and older

Cause

An internal code defect causes the problem.

Resolution

There is no work around for the problem. It requires new code to resolve.

The issue is resolved with code change starting with the r21.2.2 release of DX NetOps Performance Management.

Upgrade to release r21.2.2 or newer to resolve the problem.

Additional Information

Issue is known internally as an internally found defect fixed in latest releases. Does not appear in Fixed Issues documentation as this was found internally prior to customers reporting the problem. Only customer found and reported defects are listed in Fixed Issues lists.