Updating the agents version within the topology (ERROR)
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Updating the agents version within the topology (ERROR)

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Article ID: 225942

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Updated On:

Products

CA Workload Automation DE - Scheduler (dSeries)

Issue/Introduction

We recently upgraded our test DE server to R12.3 and also our test agents to R12.0.  We started to update the version on the agent in the topology view from R11.# to R12.0.  Most have been updated without any issue but on one of the agents we received the following error message:

[Tue Oct 12 07:50:10 EDT 2021] [CAWA_TEST] - Update AGENT AGENT01
[Tue Oct 12 07:50:10 EDT 2021] [CAWA_TEST] - Agent AGENT01 could not be updated
com.ca.wa.publiclibrary.library.validation.ValidationException: Duplicated user id: DOMAIN1\user1

Now in the past we have had duplicate user IDs in the topology but the domain was set as both lower and upper case.

Example, on the above agent we have DOMAIN1\user1 and domain1\user1.  and jobs were coded with either or.

Is Workload Automation no longer case sensitive?  Is this documented somewhere so we can review.

We need to make sure we can safely remove the duplicate IDs so we can update the version of the agent.

Environment

Release : 12.3

Component : CA WORKLOAD AUTOMATION DE (DSERIES)

Cause

Duplicate agent user ID for Windows is not allowed in DE 12.3 onwards.

Resolution

When defining an agent user, the User ID value is case-insensitive for Windows.

Remove any duplicate user IDs from Agent user in the Topology.

Additional Information

Workload Automation DE 12.3 Release Notes Fixed Issues;