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CA Search Server Service Fails to Start

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Article ID: 225886

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

When starting the CA Service Management Search Server service, the following error is encountered:

Cause

In the Search Server log directory,  i.e C:\Program Files\CA\SC\CASearchServer\elasticsearch-7.10.2\logs, there will be a searchserver-stderr-XXXX log file where XXXX is the current date of the startup attempt.  

An entry similar to the following appears:

20XX-01-01 00:00:00 Commons Daemon procrun stderr initialized
ERROR: Temporary file directory [C:\Users\ADMINI~1\AppData\Local\Temp\2\elasticsearch] does not exist or is not accessible

Environment

Service Management 17.3

Search Server

All Supported Operating Systems

Resolution

Based on the error message within the Search Server log, one can simply create a directory in the specified location (i.e. create a directory called "elasticsearch" in location "C:\Users\ADMINI~1\AppData\Local\Temp\2")

This directory is most likely the "temp" directory on the Windows Server.  

The "elasticsearch" directory can be empty and does not need to have any content.

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