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CA Search Server Failed To Start

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Article ID: 225886

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Updated On:

Products

CA Service Desk Manager

Issue/Introduction

When starting CA Search Server the following error is encountered:

Windows could not start the CA Service Management Search Server service on Local Computer.

Error 1067: The process terminated unexpectedly

Cause

Examining the Search Server logs, ie:  C:\Program Files\CA\SC\CASearchServer\elasticsearch-7.10.2\logs, there will be a searchserver-stderr-XXXX log file (XXXX is the current date of the startup attempt).  An entry will appear such as:

20XX-01-01 00:00:00 Commons Daemon procrun stderr initialized
ERROR: Temporary file directory [C:\Users\ADMINI~1\AppData\Local\Temp\2\elasticsearch] does not exist or is not accessible

Environment

Release : 17.3.x

Component : CA Search Server

Resolution

One can simply create a directory in the specified location, ie, create directory "elasticsearch" in location "C:\Users\ADMINI~1\AppData\Local\Temp\2".  

This directory is most likely the "temp" directory on the Windows Server.  

The "elasticsearch" directory can be empty and does not need to have any content populated.