Robots not resolving to hostname
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Robots not resolving to hostname

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Article ID: 225684

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

We have some robots that are alerting on their inbound IP address. I've tried manually modifying Name Services tab as some KB articles say to do, but the changes do not take affect. How can we fix this? The columns for hostname and IP seem to be reversed.

Environment

  • Release: 20.3 or higher
  • Component: UIM - ROBOT
  • nas

Cause

  • Name services administration tasks

Resolution

In the Hub GUI, in Name Services, delete the existing erroneous entries.

Add the proper hostname and IP entries and LOCK them.

The Lock option lets you protect the entry from being modified.

If there is NAT involved, search on "NAT" here in the techdocs:

controller IM configuration

Check what the hostname resolves to via nslookup <hostname> and nslookup <ip_address>

Try deleting those name entries and setting the hostname and IP address explicitly (not Automatically detect) in the robot-> controller GUI.

Then, select the controller probe and using the callback via Ctrl-P, in Expert Mode, run the callbacks to clean the niscache and reset the robot device id.

Make sure the explicit hostname and IP settings are configured in the robot.cfg:

   robotip = <ipaddress>
   robotname = <hostname>

The robot will then restart.

Then see if the issue gets resolved.