Symantec Workflow Server service is started with ITMS installation and consumes up to 1.5 GB RAM

book

Article ID: 225682

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

The customer did an ITMS clean install. Immediately after ITMS installed, Workflow server (..\Altiris\Workflow\Server Extensions\LogicBase.ServerExtensions.exe) consumed 150 MB RAM, but after night it is consuming up to 1500MB impacting ITMS server performance.

Cause

Known issue. This issue occurs only on a SMP Server where Workflow itself isn't installed/configured manually by the user.

The problem was in the not deallocated unmanaged memory which was allocated for IIS apps management. Our Dev team made sure Dispose() was called for  Microsoft.Web.Administration.ServerManager object each time it is used and abandoned. After the fix, the private working memory set of Logicbase.Extensions.exe is 150 Mbs, which is 10 times less.

Environment

ITMS 8.6 RTM (GA), 8.6 RU1

Resolution

This issue has been addressed in our next ITMS release: 8.6 RU2.

A pointfix is available for those customers with ITMS 8.6 GA and 8.6 RU1. The pointfix is ONLY required for cases of Workflow base (but not full server) installed along with ITMS.  There is an updated DLL with the fix: Logicbase.ServerExtensions.Core.dll

"LogicBase.ServerExtensions.Core.dll" is replaced in "C:\Program Files\Altiris\Workflow\Shared\logicbaselib"

Please refer to our Pointfix pages under the Workflow Solution section:

ITMS 8.6 POST GA Pointfixes

See 215121

ITMS 8.6 POST RU1 Pointfixes

See 221269

Attachments