Unable to start Vertica Data Repository database due to catalog error
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Unable to start Vertica Data Repository database due to catalog error

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Article ID: 225679

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

When trying to start the vertica database using adminTools, the cmd window flashes, closes, returns to the admintools GUI and nothing happens.

 

When trying to start the Data Repository Vertica database the following error is seen.

bash-4.1$ /opt/vertica/bin/adminTools -t start_db -d drdata -p dbpass
Unable to read database catalogs - cannot start database.
Database drdata did not start successfully: Unable to read database catalogs

The same error is seen trying to start the database using the adminTools UI.

We also see the following errors in the adminTools.log file each time an attempt is made to restart the database.

2021-10-06 12:26:00.052 at_exec/216777:0x7fc81fec5700 [CatalogEditor.sendCmd] <ERROR> Exception encountered while running catalog editor
Traceback (most recent call last):
  File "/opt/vertica/oss/python/lib/python2.7/site-packages/vertica/tools/CatalogEditor.py", line 120, in sendCmd
    self.ceproc.stdin.write(cmd_string)
IOError: [Errno 32] Broken pipe
2021-10-06 12:26:00.052 at_exec/216777:0x7fc81fec5700 [CatalogEditor.sendCmd] <ERROR> 
Vertica Catalog Editor: broken pipe detected
Added stdout messages to error.
BEGIN CE output
END CE output
2021-10-06 12:26:00.052 at_exec/216777:0x7fc81fec5700 [ATRunner.exec_module] <ERROR> command got exception: Could not load from Catalog Editor.
 Catalog Editor state 
CatalogEditor instance
Closed? False
CE subprocess = <subprocess.Popen object at 0x7fc819182990>
CE proc.poll = 1 CE proc.stdin = <open file '<fdopen>', mode 'wb' at 0x7fc8191cbb70> CE proc.stdout = <open file '<fdopen>', mode 'rb' at 0x7fc8191cbae0> Exception was Broken pipe
Vertica Catalog Editor: broken pipe detected
Added stdout messages to error.
BEGIN CE output
END CE output
2021-10-06 12:26:00.072 admintools/216675:0x7f6f3d9c5700 [compute_vdatabase.handle_results] <INFO> Handling results for compute_vdatabase
2021-10-06 12:26:00.073 admintools/216675:0x7f6f3d9c5700 [NewSSH.computeVDatabase] <WARNING> There was a problem running the catalog editor on host <IPAddress>. If all hosts have problems, then the database will not be able to start. Problem details: <ATResult> status=1 host=<IPAddress> content={}

Environment

All supported DX NetOps Performance Management releases

Cause

The LANG value set on the system is not set correctly to en_US.UTF-8 as required by Vertica.

Resolution

The LANG value must be set to en_US.UTF-8.

To see the current LANG value run the command: locale

If the LANG value is not en_US.UTF-8 set it to that value.

Once set properly the database will restart.

Additional Information

Setting the locale on your system is beyond the scope of Broadcom support.

One possible way to do it is to edit the /home/<USER>/.bashrc file for the database admin user (dradmin by default)

add these lines:

# added by YOUR-NAME-HERE to set lang/locale settings to allow vertica to start.

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8
export LANGUAGE=en_US.UTF-8

save the file, log out and back in as dradmin user.