Change File Owner to service account for CAPC

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Article ID: 225659

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Can I change the owner of the files under /opt/CAPM/PerformanceCenter to a service account. We don't have root access to the servers unless requested.

How to change the owner of a Data Collector installation from a root user to a non-root user?

Cause

Installed as root user but root user access was revoked and requires special permission on a case by case basis.

Environment

All supported DX NetOps Performance Management releases

Resolution

Before changing the install owner to a non-root sudo-root user, it is required that the new user be properly configured to manage the installation. The steps to configure the user for proper sudo rights access are found on the Prepare to Install NetOps Portal documentation page.

The simplest method to change the Portal install ownership from root to non-root sudo-root user is a reinstall. All releases r20.2.1+ will allow overinstall using a different user if already installed and owned using the root user. This ONLY works moving from root owned installs to non-root sudo-root user owned installs. It will not work to modify the owner from one non-root user to another non-root user.

It is highly recommended that a backup of the Portal system be made and set aside for use in a restoration should something go wrong. Follow the steps in the Back up NetOps Portal documentation. If restoration is needed follow the Restore NetOps Portal documentation.

To reinstall the Portal so it's owned by a new non-root sudo-root user follow the Install NetOps Portal documentation and provide the new user when prompted.