Modern UI response incorrect for one user in automation testing
search cancel

Modern UI response incorrect for one user in automation testing

book

Article ID: 225464

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When you enter the Modern User Experience / Interface (UX/UI), one of the pages is generating two different responses for two different users. The different responses are impacting your ability to perform a load and performance test on the merged / Modern UI. Why is the response different?

The page URL is:

https://<Clarityserver>/ppm/rest/v1/private/personalizations?fields=userid,component,personalizations&sort=userid&filter=((component%20=%20%27project%27)%20and%20(userid%20=%20111111))&_cb=......

Bad response:

{"_pageSize":25,"_self":"https://www.<Clarityserver>.com/ppm/rest/v1/private/personalizations?filter=%28%28component+%3D+%27project%27%29+and+%28userid+%3D+111111%29%29&fields=userid%2Ccomponent%2Cpersonalizations&sort=userid","_totalCount":0,"_results":[],"_recordsReturned":0}

Environment

Release : 15.9.2

Component : Clarity MUX UI Usability

Cause

This is due to an issue with the custom automation script

Resolution

Custom automation scripts are not supported, so you will need to work with your automation script developer to fix the script.

Workaround: 

Flush Clarity server cache