Removing UC_SYSTEM_SETTINGS key LDAP does not revert to default
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Removing UC_SYSTEM_SETTINGS key LDAP does not revert to default

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Article ID: 225449

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Updated On:

Products

CA Automic One Automation

Issue/Introduction

In client 0, removing the key LDAP from UC_SYSTEM_SETTINGS will not set it's value to the default of "N", but keep it as the value it had when deleting.  This is a different behavior compared to other keys within UC_SYSTEM_SETTINGS.  This means that LDAP will continue working even if it's been deleted from UC_SYSTEM_SETTINGS with the intention of turning it off.

Steps to reproduce

  1. Have a system setup with LDAP set to Y in UC_SYSTEM_SETTINGS and LDAP working
  2. Log into client 0 and open UC_SYSTEM_SETTINGS
  3. Remove LDAP line
  4. Save changes to UC_SYSTEM_SETTINGS

    Expected behavior:
    LDAP should revert to default value of 'N'
    LDAP should no longer work, WP should show default value:
    U00011847 'LDAP' set to 'N'

    Actual behavior:
    LDAP still works, WP log still shows:
    U00011847 'LDAP' set to 'Y'.

  5. Restart system

    Expected behavior:
    LDAP should revert to default value of 'N'
    LDAP should no longer work, WP should show:
    U00011847 'LDAP' set to 'N'.

    Actual behavior:
    LDAP still works, WP log still shows:
    U00011847 'LDAP' set to 'Y'.

Environment

Release : 12.3

Component : AUTOMATION ENGINE

Cause

This is caused by a defect in the product

Resolution

This will be fixed in 12.3.7 so that LDAP goes back to the default of "N" if it is removed from UC_SYSTEM_SETTINGS

Workaround

If the intent is to turn off LDAP, always explicitly specify "N" instead of just removing the row from UC_SYSTEM_SETTINGS