Import Integration Mappings Job error for SSO enabled environment

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Article ID: 225398

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

On any SSO enabled environment, the Import Integration Mapping job fails for Clarity - Rally integration even though all the Pre Requisites are defined in the environment. 

Cause

STEPS TO REPRODUCE: 

1. Login to a Clarity instance which is SSO enabled.
2. Navigate to Administration - General Settings - Integrations
3. Create an Integration Mapping as mentioned in the product guide below 
https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/clarity-project-and-portfolio-management-ppm-on-premise/15-9-3/using/Getting-Started-with-Clarity-Administration/Clarity-Connections---Rally-Integrations.html
4. Once the mapping is completed, run the Import Integration Mapping job. 

Expected: The job completes successfully and retrieves all the supported attributes from the Rally workspace.
Actual: The job instance shows as completed but the job log shows all the attributes errored out with the below error message. 

Processing Import Integration Mappings . Time: Thu Sep 30 18:21:08 AEST 2021

Error while getting the existing clarity attributes for clarity object: idea
java.io.IOException: HTTP/1.1 302 

Error while getting the existing clarity attributes for clarity object: abc_domain
java.io.IOException: HTTP/1.1 302 

Error while getting the existing clarity attributes for clarity object: abc_epic
java.io.IOException: HTTP/1.1 302 

No lookup type attributes are found to load Rally data to Clarity system

Finished processing Import Integration Mappings . Time: Thu Sep 30 18:21:11 AEST 2021

Resolution

This has been flagged as defect and is under Engineering review - DE62778

The work around is to disable the SSO and then run the Import Integration Mapping job