Admin jaspersoft command fails with jNullPointerException exception
search cancel

Admin jaspersoft command fails with jNullPointerException exception

book

Article ID: 225389

calendar_today

Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

In a clarity and jaspersoft integration where all features of advanced reporting reports is looking good the following admin jaspersoft command fails:

admin jaspersoft syncPPMContext -userName

Failed to process the jasper command. : Cannot invoke "com.jaspersoft._2007.sl.xmlschema.SchemaType.getDataSources()" because the return value of "com.jaspersoft.fs.domainmodifer.api.MutableDomainSchema.getRootNode()" is null

Error occurred: java.lang.NullPointerException: Cannot invoke "com.jaspersoft._2007.sl.xmlschema.SchemaType.getDataSources()" because the return value of "com.jaspersoft.fs.domainmodifer.api.MutableDomainSchema.getRootNode()" is null

Environment

Clarity 15.9.1 and Jaspersoft server 7.1

 

Cause

OpenJDK set to a higher non-supported version on the clarity server. 

Resolution

The JAVA HOME was set to OpenJDK 16.01 and whereas the one certified and shipped with clarity is AdoptOpenJDK 11.0.9.1+1. 

Steps to resolve:

  1. Install OpenJDK 11 and update JAVA home environmental variable
  2. Update Clarity JAVA home via properties.xml
  3. Stop and start clarity APP services
  4. The admin jaspersoft command should now work without the JAVA NullPointerException