API Endpoint not accessible from TDM portal

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Article ID: 225269

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

     We are making use of services/API's in our space that are being used for data creation. These services (GET/POST/PUT) are accessible from Javelin (and postman) and are getting the desired output. However, when we are running the generator (that are included with these Javelin workflows as part of publish action) from TDM portal, we see that few of the endpoints are not accessible.

       We did include the required endpoints in the exception as part of the proxy settings as suggested in the thread (Proxy error messages appear in the Endpoint Protection Manager Cloud tab > Troubleshooting (broadcom.com)), but the issue still persist. Please note that we are able to execute the Javelin workflow in the TDM server as well as local machine, but we are having issues with accessing the same from generators. 

Please can you advise. We are happy to have a call scheduled so that we can walkthrough the issue for more details.

Generator log - failure

2021-08-03 06:33:19 - Run flow: D:\CA Test Data Manager Portal\\Jobs\Job_118692\Action_13_Workflow.vwf | Allocated Managed memory: 1133464 bytes | private process memory: 20 MB | working Set mem 16 | virtual mem: 546 | handlecount: 192
2021-08-03 06:33:32 - Calling Invoker
2021-08-03 06:33:32 - Running Test Case: Flowchart
2021-08-03 06:33:32 - Executing Step: SqlServerActivity||Customer record for Creation
2021-08-03 06:33:32 - ConnectionStringService:GetConnectionString Username: TDMADMIN
2021-08-03 06:33:32 - ConnectionStringService:GetConnectionString connectionStringSettings.Username: TDMADMIN
2021-08-03 06:33:32 - ConnectionStringBuilder:GetConnectionString providerDetails.provider: System.Data.SqlClient
2021-08-03 06:33:32 - Connecting to Sql Server database...
2021-08-03 06:33:32 - Executing query: select top 1 * from Wireless.dbo.RW_CustMaster  where status is null order by ssnLast4
2021-08-03 06:33:32 - Executing Step: SqlServerActivity||Customer record for Creation
2021-08-03 06:33:32 - ConnectionStringService:GetConnectionString Username: TDMADMIN
2021-08-03 06:33:32 - ConnectionStringService:GetConnectionString connectionStringSettings.Username: TDMADMIN
2021-08-03 06:33:32 - ConnectionStringBuilder:GetConnectionString providerDetails.provider: System.Data.SqlClient
2021-08-03 06:33:32 - Connecting to Sql Server database...
2021-08-03 06:33:32 - Executing query: update RW_CUSTMASTER set status='USED' where ssnLast4=0231 and emailaddress='[email protected]'
2021-08-03 06:33:32 - Executing Step: LogActivity
2021-08-03 06:33:32 - Create Customer
2021-08-03 06:33:32 - Executing Step: LogActivity
2021-08-03 06:33:32 - Endpoint for RW Create Customer API: https://test.api.test.io/wireless/retail/v1/customer-management-service/customer
2021-08-03 06:33:32 - Executing Step: RESTPutActivity|CreateCustomer
2021-08-03 06:33:33 - Error executing RESTPutActivity|CreateCustomer: Error reading JToken from JsonReader. Path '', line 0, position 0.
2021-08-03 06:33:33 - Test Case: Flowchart Execution Complete
2021-08-03 06:33:33 - Exception occurred while executing workflow: Object reference not set to an instance of an object. and stacktrace =    at System.Activities.WorkflowApplication.Invoke(Activity activity, IDictionary`2 inputs, WorkflowInstanceExtensionManager extensions, TimeSpan timeout)
   at System.Activities.WorkflowInvoker.Invoke(Activity workflow, TimeSpan timeout, WorkflowInstanceExtensionManager extensions)
   at GridTools.Javelin.Common.JavelinHelper.ExecuteWorkflow()

2021-08-03 06:33:33 - Execution Complete

Cause

By default portal service starts as a local system account. This account do not have access to read proxy details. Since the end point requires proxy details to establish connection, getting an error while calling javelin flow from publish action. Where as Javelin application, runs with the user account which has access to the proxy details. So, its working in Javelin without any additional configuration.

Environment

Release : 4.9

Component : TDM Web Portal

Resolution

Go to services and change the user account for Portal service from default local account to any specific user account and restart the portal service.