Unable to register to a Task Server. HTTP status 404: The requested URL does not exist on the server or the server is down (0x8FA10194)

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Article ID: 225167

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Updated On:

Products

IT Management Suite

Issue/Introduction

The customer is migrating to a new SMP (Symantec Management Platform) 8.6 server. As part of the upgrade/migration process, the customer also upgraded his Site Servers from Windows Server 2008 to 2016. After the did that and the Altiris Agent upgraded to 8.6, he noticed that any client machine can't register to these Task Servers nor the Task Servers to itself after re-directing them to the new SMP Server.

He already tried to remove and reinstall the Task Agent but still the same results.

He is not using HTTP in this environment. He only uses HTTPS.

The agent logs from the Site Server showed that the agent itself is trying to register but it can't be complete because it thinks that it is paused (even after checking the recommendations under KB 176128 "Getting: The server is currently paused (0x8004200E) when trying to reach GetClientTaskServers.aspx") or the URL doesn't exist:

Entry 1:
Server 'https:siteserver01.domain.com:443' connection succeeded, total attempts 184, errors 1
-----------------------------------------------------------------------------------------------------
Date: 9/9/2021 3:11:38 PM, Tick Count: 249489328 (2.21:18:09.3280000), Size: 318 B
Process: AeXNSAgent.exe (6976), Thread ID: 7416, Module: AeXNetMon.dll
Priority: 16, Source: NetworkMonitor


Entry 2:
Task Server Connection: Failed to request 'https://siteserver01.domain.com:443/Altiris/ClientTaskServer/Register.aspx?resTypeGuid={2C3CB3BB-FEE9-48DF-804F-90856198B600}&sysType=Win64&version=8.6.1119&resourceGuid=0fd1e768-f961-47eb-a4cd-440c45008573&crc=000800060000045F', error: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond (0x8007274C)
-----------------------------------------------------------------------------------------------------
Date: 28/09/2021 13:25:45, Tick Count: 313060671 (3.14:57:40.6710000), Size: 715 B
Process: AeXNSAgent.exe (2416), Thread ID: 16368, Module: client task agent.dll
Priority: 2, Source: Client Task Agent


Entry 3:
Task Server Connection: Failed to register on Task Server 'siteserver01.domain.com' over 'https', error: The server is currently paused (0x8004200E)
-----------------------------------------------------------------------------------------------------
Date: 9/9/2021 3:11:38 PM, Tick Count: 249489343 (2.21:18:09.3430000), Size: 383 B
Process: AeXNSAgent.exe (6976), Thread ID: 7416, Module: client task agent.dll
Priority: 2, Source: Client Task Agent
File: C:\Usersg731047\Downloads\ARAPP01 Logs\Logs\Agent.log

 

Entry 4:
Operation 'Direct: Head' failed. 
Protocol: HTTPS 
Host: siteserver01.domain.com:443 
Path: /Altiris/ClientTaskServer/Register.aspx 
Connection Id: 268.6976 
Communication profile Id: {FEE24B78-8CC2-480C-9E5C-777C6C8DB81F} 
Throttling: 2 34 0 
Error type: HTTP error 
Error code: HTTP status 404: The requested URL does not exist on the server or the server is down (0x8FA10194) 
Error note: 404 Not Found 
Server HTTPS connection info: 
   Server certificate: 
      Serial number: 64 dc 03 fd 7f 2e 7e f3 e8 24 8b 49 a3 78 7f 0a 34 52 fb a7 
      Thumbprint: 11 de 2b 08 51 2e 11 d8 ab 9b 30 1a 13 28 c8 ad da 55 e5 da 
   Cryptographic protocol: TLS 1.2 
   Cipher suite: TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 
   Cipher algorithm: AES 
   Cipher key length: 256 
   Hash algorithm:  
   Hash length: 0 
   Key exchange algorithm: ECDH 
   Key length: 255
-----------------------------------------------------------------------------------------------------
Date: 9/9/2021 3:11:38 PM, Tick Count: 249489343 (2.21:18:09.3430000), Size: 1.08 KB
Process: AeXNSAgent.exe (6976), Thread ID: 7416, Module: AeXNetComms.dll
Priority: 1, Source: NetworkOperation

Cause

After further troubleshooting, since we couldn't reach out the usual "/Altiris/ClientTaskServer/Register.aspx" on that Task Server from any machine (including the SMP server itself) other than the Task Server itself, the customer talked to his network team.

They found that they had an internal firewall that was blocking some of the default ports that we needed to be available. After those were opened, The Task Server was able to register just fine.

 

Environment

ITMS 8.5, 8.6

Resolution

Make sure the proper ports are open in your firewall, either in the Task Server itself or any other that you may have internally in your network.
See KB 184952 "Ports and Protocols for Symantec IT Management Suite (ITMS) 7.5, 7.5 SP1, 7.6, 8.0, 8.1, 8.5 and 8.6"