Data Center Security (DCS) manager install fails with error: The CREATE DATABASE statement failed
search cancel

Data Center Security (DCS) manager install fails with error: The CREATE DATABASE statement failed

book

Article ID: 224947

calendar_today

Updated On:

Products

Data Center Security Server Advanced

Issue/Introduction

You see an error during the database creation of a fresh DCS Manager install:

The CREATE DATABASE statement failed. The primary file must be at least x MB to accommodate a copy of the model database.

Or the install wizard prompts with error

Error Code: -1 failed to create database

Environment

Data Center Security: Server Advanced 6.8.x
Data Center Security: Server Advanced 6.9.x
Data Center Security: Server Advanced 6.10.x

Cause

The model database template is too large

Resolution

Decrease the size of the model database following the steps below: 

  1. Open Microsoft SQL Server Management Studio
  2. Under Databases> System Databases, right-click on Model and open Properties
  3. Under 'Files', change the 'Initial Size (MB)' to 1.
  4. Click OK