Maximum locks detected on SDM Web UI

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Article ID: 224930

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Experiencing some performance issues in our SDM implementation.

noticed that when we are having such issues the current locks are very high.

Cause

Performance problem came from integrations.  Third party tool was using SOAP to exchange information with SDM and this was the problem. This system was performing thousands of logins every day, among other heavy operations. 

Environment

Release : 17.3

Component : SDM - Web UI and Performance

Resolution

Migrated from SOAP to REST in order to prevent that system to login multiples times, now we are using the same Access Key instead.

Additional Information

Additional information on turning up logging for SOAP Web Services is available here:

Activating Tomcat Tracing for pdm_export, Attachments and SOAP Web Services calls
https://knowledge.broadcom.com/external/article?articleId=137240