Issue Installing AIX Agent - Agent will not start after install/upgrade
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Issue Installing AIX Agent - Agent will not start after install/upgrade

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Article ID: 224891

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

New agent install in production. AIX agent will not start after install. The install ran fine, but when trying to start agent it will go into STOPPED status and will not run when doing right click and START.

Environment

Release : 9.3

Component :

Cause

Communications error with RMI Server

Resolution

This seems to be an issue with AIX only.

Troubleshooting steps and resolution:

  1. Verify versions and compatibility
  2. Verified compatibility matrix - shows correct versions for java, and OS
  3. Agent log not showing any errors
  4. RMI Server log not showing any errors
  5. No errors in install log
  6. Reinstall - no changes; still no errors in the install log
  7. Restarted RMI on master
  8. Restarted the agent
  9. Agent then started and connected
  10. Tested and working as expected

For this AIX agent install, it was necessary to restart the RMI server on the Master to establish connection.

Additional Information

Restart RMI on master, then restart agent on AIX