"Error getting Schema" when creating Adhoc reports
search cancel

"Error getting Schema" when creating Adhoc reports

book

Article ID: 224889

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

"Error getting schema" is received for only one user they try to create or access any Adhoc Report

The user is able to access out of the box reports

Environment

Release : 15.9.3

Component : CLARITY USERS, GROUPS, OBS ADMINISTRATION

Cause

The system had custom roles with the permissions needed.  User did not have these Roles assigned in Advanced Reporting

 

Resolution

Assigned the correct roles to the user

Additional Information

  • If this issue returns, it is because the user is not assigned to the correct Group in Clarity, then the 'Create and Update Jaspersoft Users' job was ran.
  • To correct, add user to the correct group in Clarity