Error : Timed out Policy Server when searching LDAP User Directory

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Article ID: 224867

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Updated On:

Products

CA Single Sign On Agents (SiteMinder) SITEMINDER

Issue/Introduction

 

When running AdminUI and searching a user by the employeeNumber in the
LDAP User Directory configuration, the browser shows the error :

     error: Timed out

 

Cause

 

From the Policy Server logs, it has been seen that the search query
reached a time out :

  smps.log 

    [11510/140183093602048][Mon Sep 06 2021
    04:17:58][SmDsLdapConnMgr.cpp:1201][ERROR][sm-Ldap-02230] Error# '85'
    during search: 'error: Timed out' Search Query =
    '(&(|(objectclass=organizationalPerson)(objectclass=inetOrgPerson)
    (objectclass=organization)(objectclass=organizationalUnit)
    (objectclass=groupOfNames)(objectclass=groupOfUniqueNames)
    (objectclass=group))(employeeNumber=myEmployeeNo))'
    for server 'myldap.mydomain.com:389'

This means that the LDAP User Directory takes too long to return the
data.

 

Resolution

 

- Investigate with the LDAP User Directory team the reason why the
  Policy Server reaches a time out when searching for employeeNumber
  and not for cn or other attributes;