Cube installation error: The table with Name of <TableName> does not exist
search cancel

Cube installation error: The table with Name of <TableName> does not exist

book

Article ID: 224850

calendar_today

Updated On:

Products

IT Analytics

Issue/Introduction

After installing, moving, or reconfiguring IT Analytics (ITA), the following error is returned when attempting to install a cube or cubes via the ITA console > Admin > Settings > Cubes Installation:

The table with Name of <TableName> does not exist.

The ITAnalytics database is confirmed to exist on the SQL Server but the ITAnalytics database, datasources, and cubes are missing from the SQL Server Analysis Services (SSAS) server.

Environment

Release : 2.9.1

Component : Cubes

Cause

The SSAS server instance is installed in tabular mode. To confirm:

  1. Using SQL Server Management Studio, connect to the Analysis Services server on which the ITA cubes are to be hosted
  2. In Object Explorer, right-click the SSAS hostname and select Properties
  3. In the Analysis Server Properties window, note the Server mode

Additional methods for determining the server mode are provided in this Microsoft KB article.

Resolution

To change the mode of the SSAS instance, uninstall the existing instance and re-install in multidimensional mode. Other methods for changing the mode without removing the installed instance exist but are not supported by Broadcom.