Bandwidth Data not polled after Router Update to 17.3.3

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Article ID: 224798

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Updated On:

Products

CA Performance Management - Usage and Administration

Issue/Introduction

Currently using CAPC\CAPM to poll MPLS based routers for Bandwidth IN\OUT stats.  Our routers have been getting code updates and after they have they are no longer reporting these stats or they are simply returning 0's as a value.

To date we have tried completely removing the devices from CAPC\CAPM\NFA altogether, verifying they are gone, then re-discovering to bring them back in. Have also had the Network Team remove SNMP from the devices and and reconfigure them.  Nothing has worked.

On the interface console where the bandwidth data is there is indeed a line to showing the polling date\times but the value is always '0'.  Almost like it is indeed polling the device but the device is returning 0' for the value.

We have another APM solution that we have used to test polling these same devices and they do seem to be reporting correctly as that application actually shows values for the snmp queries.

This is somewhat urgent as we have more and more sites that are no longer reporting data.

Cause

 Cisco bug CSCvy25845: SNMP: ifHCInOctets - snmpwalk on sub-interface octet counter does not increase on version 17.3.3

 

These bug impacts the counters for those OID. If you wish, you can downgrade to version 17.3.2 as this version was not affected with the bug.

 

 

 

Environment

Release : 20.2

Component :

Resolution

Cisco bug CSCvy25845: SNMP: ifHCInOctets - snmpwalk on sub-interface octet counter does not increase.

These bug impacts the counters for those OID. If you wish, you can downgrade to version 17.3.2 as this version was not affected with the bug.

If not the bug includes the following workaround:

Use CLI alternative:

show vlans dot1q XXX

Cisco to fix bug